ClassicPress PetitionsClassicPress Petitions
This is a read-only archive. Post or comment on the live version of this page on our forums.

Increase the minimum PHP version to 5.6

September 7, 2018 · 14:42 · Scott Bowler

+10 more
Request: Modify feature

I agree, but this will need to be revisited in 2019 when PHP stops issuing security updates to version 5.6.

Adam Alicki
James Nylen

I respect the idea here, but I don't think we can reasonably pull it off in a short time frame. See:

28.1% of WordPress installs are using PHP 5.5 or earlier, so these are all users that we would be excluding.

Rudy Brinkman

I agree, 5.6.x should be the minimum. Webhosters still allowing lower PHP versions should be forced to update anyway (this is from a webhoster point of view :) )


Agreed with 5.6 as PHP minimum.

It is also being discussed in this thread:

Dennis Ploetner

PHP 5.6 will get security updates until the end of 2018 if I understand this page -> right. This is also true for PHP 7.0 btw.