I agree, but this will need to be revisited in 2019 when PHP stops issuing security updates to version 5.6.
I disagree, minimum version should be 7.x
I respect the idea here, but I don't think we can reasonably pull it off in a short time frame. See: https://wordpress.org/about/stats/
28.1% of WordPress installs are using PHP 5.5 or earlier, so these are all users that we would be excluding.
I agree, 5.6.x should be the minimum. Webhosters still allowing lower PHP versions should be forced to update anyway (this is from a webhoster point of view :) )
Agreed with 5.6 as PHP minimum.
It is also being discussed in this thread:https://vote.classicpress.net/posts/6/minimum-php-version-should-be-7-0
PHP 5.6 will get security updates until the end of 2018 if I understand this page -> http://php.net/supported-versions.php right. This is also true for PHP 7.0 btw.